
 

1 
DEER PARK PUBLIC LIBRARY 
3009 Center St. | Deer Park, TX 77536 | 281-478-7208 | http://www.deerparktx.gov/library 
 

 
1.13.2018 

 
 

A student with at least basic knowledge of Excel learns how to insert and manipulate graphs and 

pivot tables in Excel. 

Learning Objectives 

At the end of class, the student will: 

● Students will understand what a Graph is. 

● Students will understand what a Pivot Table is. 

● Students will understand when to use a Graph and when to use a Pivot Table. 

● Students will understand how to create and manipulate a Graph. 

● Students will understand how to create and manipulate a Pivot Table. 

 

Lesson Prep Work. 

(30 min, at a minimum, prior to student arrival). 

● Get in early to test for technology failure, because it will happen :-). 

● Save Graphs and Pivot Tables.xlsx to the desktop on each computer. 

● Print handouts. 

 

Lesson Prerequisites. 

● Excel Basics or equivalent skills. 

 

 

Lesson Outline. 

The lesson is completed in one 60-minute class session. 

 

(5 min) Introduction 

● Introduce instructor, students. 

○ Ask students for their names and what experience they have using Excel. 

● Let students know it’s okay to take phone calls, but ask them to put their phone on vibrate and 

answer calls outside the classroom. 

● Inform students that they can sit back and watch if the class is too advanced. 

● Inform students they can go to the bathroom, they don’t need permission. 

● State/show order in which class will happen. Explain scope of class. 
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(5) Vocabulary 

● Open Graphs and Pivot Tables.xlsx from the desktop. 

● Ribbon and Tabs 

○ Home Tab – where your most frequently accessed features are. 

○ Insert Tab – where you can add new content to your spreadsheet. 

○ Contextual Tabs – tabs that only appear when you have a specific object selected. You 

don’t need graph editing tools until you have a graph in your worksheet. 

● Workbook and Worksheet 

○ Workbook - made up of one or more worksheets. It is the actual file. 

○ Worksheet – individual sheets in workbook. Accessed through the tabs at the bottom of 

the workbook. 

● What is a graph? 

○ A visual representation of data.  

● What is a pivot table? 

○ An interactive way to quickly summarize large amounts of data.  

○ Use a PivotTable report to analyze numerical data in detail and to answer unanticipated 

questions about your data. 

● Both of these tools are data summary tools. 

 

(5) Create a Graph 

● Discussion/Explanation 

○ When is using a graph appropriate? 

■ When you want to visually represent data, you can use a graph. 

■ Graphs work best report on 2 axes of information, not more. 

○ Where have you seen graphs used before? 

■ On TV – Presidential stats, weather comparisons with previous years. 

■ Financial reports – show how much money you have today v. last year. 

● Activity: Insert a graph showing the earnings for all stores in Denver for last year. 

○ Click anywhere in your data. 

■ Teacher’s Tip: Explain that if you are not clicked into a cell with text in it, you will 

get a blank graph. Make sure you always start by clicking on the data you want to 

display. 

○ Go to the Insert tab. 

■ Take a second to look at the various chart types. 

■ If you hover on any of the buttons, you get a brief summary of what that graph 

will show you if you use it. 

■ Ask students: which of the graph types would work best for this question? 

■ When in doubt, hover on a bunch of different types of graphs to get a preview. 

Use that to see if it shows you what you want to see. 

○ Click on one of the graph types of your student suggestions. 

■ Teacher’s Tip: Point out that we have contextual tabs that appear while we have 

the graph selected. If we click off the graph, the tabs go away. When we click on 

the graph, they reappear. The only time we have graph editing tools is when we 

have a graph selected. 

○ Click on Change Chart Type in the Type grouping. 

○ Select the 2D column chart and click OK.  
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(5) Edit the Graph 

● Activity: Make the graph pretty.  

○ Make the graph bigger using the handles on the corners. 

○ Change the graph title to 2014 Store Earnings. 

○ Click on a different layout in the Chart Styles grouping. 

○ Click on a different color using Change Color in the Chart Styles grouping. 

○ Click the plus in the upper right corner of the graph to turn on and off features like Axis 

Title, Chart Title, Data Labels, etc. 

○ Delete the graph by clicking in the blank space of the graph and pressing delete on the 

keyboard. 

 

(10) Change How the Data is Displayed  

● Activity: Insert a graph comparing how much each location made in March. 

○ Ask students: “what kind of graph would best work to compare income of locations for a 

single month?” 

○ Click anywhere in the data. 

○ Go to the Insert tab. 

○ Click on Pie Charts. 

○ Click on the first Pie Chart in the list. 

■ The chart is currently showing what percentage the Denver store earned each 

month of it’s total yearly earnings. The graph is displaying the wrong axis. 

○ Click on Switch Row/Column in the Data grouping. 

■ Point out that the graph is showing January. We need March. 

○ Click on Select Data. 

■ Excel pulls from the top of the list.  

■ We can un-check the data we don’t want displayed in the graph. 

○ Uncheck the boxes next to January and February and click OK.  

● Activity: Change the graph to show how much each store contributed to total earnings for 

every month. 

○ Click on Change Chart Type in the Type grouping. 

○ Click on Column. 

○ Click on 100% Stacked Column chart type and select the first one. 

○ Click on the graph that displays how much each store contributed to total earnings each 

month. 

■ The graph we added doesn’t show January or February. Why? 

○ Click on Select Data in the Data grouping. 

○ Check the boxes next to January and February and click OK. 

 

(5) Insert a Pivot Tables 

● Discussion/Explanation 

○ A pivot table is a program tool that allows you to reorganize and summarize selected 

columns and rows of data in a spreadsheet or database table to obtain a desired report. 

A pivot table doesn't actually change the spreadsheet or database itself. 

○ When is using a pivot table appropriate? 

■ Again, you use it to summarize a large chunk of data. 
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○ Open the Pivot Tables worksheet from the bottom of the workbook. 

○ Tell students that you want them to tell you how much inventory you have in Ford and in 

Toyota, and while they’re at it, you want it broken down by the type of vehicle (car, 

truck, SUV). 

■ Students should look confused for a minute – tell them you are going to show 

them a shortcut to get all this information. 

● Activity: Insert a pivot table and report on Brand and Type. 

○ Click anywhere in the data. 

○ Go to the Insert tab. 

○ Click on Pivot Table. 

○ Click on OK. 

■ Explain that the Fields we can choose from are the column headings from the 

worksheet with all our car information on it. 

■ We can drag and drop these labels to create data reports. 

■ Teacher’s Tip: it is much easier if you demo this process for your students before 

having them follow along. 

○ Drag and drop Brand to the Column Labels field. 

■ You will see the brands populate horizontally across the page. These will be your 

column headings. 

○ Drag and drop Type to the Row Labels field. 

■ You will see car, truck and SUV populate vertically on your page. These will be 

your row headings. 

○ Drag and drop Price to the Values field. 

■ The totals appear in the grid we set up with the column and row labels. This is 

the total amount of inventory we have in each type of vehicle. 

■ Ask students: “can you use this table to tell me how much inventory we have in 

2014 Fords?” 

■ Teacher’s Tip: Just like with Graphs, if you click away from the pivot table, you 

lose the Pivot Table tabs. You can bring back your sidebar and tabs by clicking 

back on your pivot table. 

○ Remove all values by unchecking them in the Fields List. 

● Comprehension Check: Build a pivot table displaying how much inventory we have in vehicles 

we have by brand, year and type. 

○ Instructor walks around the room to assist struggling students. 

○ After the pivot table if built, show students why it’s called a pivot table. Move the fields 

around to pivot the appearance of the table. 

○ End with Brand in the columns field and Year above Type in the Rows field. 

 

(5) Pivot Table Functions 

● Explain 

○ Currently, we have only looked at using the AutoSum function, adding all of the values 

in the Price column. 

○ What if I wanted to look at how many vehicles I had in each category? 

○ You can change the function that is used in your pivot tables. If students need to know 

more about functions, send them to the Formulas and Functions class. 

● Activity: Change pivot table to perform a count. 
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○ Click on the drop down arrow next to Sum of Price in the values field. 

○ Click on Value Field Settings. 

■ Give a brief overview of the functions available in the dialog box that appears. 

○ Click on Count and click OK. 

■ Teacher’s Tip: it can be worthwhile to point out the Number Format button for 

changing values to appear as numbers, currency, etc. 

● Comprehension Check: students change the function back to Sum. 

○ Instructor walks around the room to assist struggling students. 

○ For students who feel particularly ambitious, ask them to use that dialog box to change 

the formatting of the values so they look like money. 

 

(10) Filter a Pivot Table 

● Explain: 

○ At this point in time, we are seeing a summary of all of the vehicles on our lot. 

○ What if we only wanted to see data regarding Fords? What about SUVs and Trucks? 

○ There are dropdown arrows next to the Row and Column Labels.  

○ Students should recognize these from the Sort and Filter class. 

● Activity: Turn on a filter to only display Fords. 

○ Click on the filter dropdown arrow for Column Labels. 

○ Uncheck Toyota and click OK. 

■ Whatever fields are checked will display in our pivot table. 

■ Here we see data related only to Fords. 

■ Notice that there are essentially two columns of repeated data though. We’ll 

come back to that in just a moment. 

○ Clear the filter from Column labels by clicking the filter icon and clicking Clear Filter 

From Brand. 

● Activity: Turn on a filter to display only SUVs and Trucks. 

○ Click on the filter icon for Row Labels. 

■ Because there are 2 fields in our row list, you only see the top one. If you have 

Year on top of Type, you will only see options for Year. 

○ Use the field select drop down menu to select Type. 

○ Uncheck Car and click OK. 

■ We now only see data related to SUVs and Trucks. 

○ Clear the filter from Type. 

■ Remember, you’ll have to use the field select dropdown menu to select Type. 

● Explain: 

○ When we filter our pivot table down so we are only showing one category of information 

(like we did with Ford earlier), we see duplicate data on the screen. It’s not useful.  

○ We can create another filter that will clean up that data. 

● Activity: Create a cleaner filter for Fords. 

○ Move Brand from the Columns area to the Filters area. 

○ Click on the filter next to Brand (All). 

○ Click on Ford and click OK. 

■ Now the values reflected are related only to Fords, but they aren’t showing 

duplicate columns of data. 

● Activity: If there is time permitting, go over slicers. 
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○ Slicers are another way of filtering data. They weren’t added to Excel until 2010. 

○ Click on Insert Slicer in the Filter grouping on the Analyze tab. 

○ Select the fields you want to filter by: Brand, Type, etc, and click OK. 

○ Click on a field to filter by that option. CTRL click to select multiple options. 

● Activity: If there’s super extra time permitting, look at adding a pivot chart. 

○ Click on Pivot Chart in the Tools grouping of the Analyze tab. 

○ Select the type of chat you want to display and click OK. 

■ All of your chart editing tools are exactly the same as what we looked at earlier in 

class. 

 

(5) Conclusion  

● Go over handout, review material, and emphasize contact info & further resources on handout. 

● Any questions? Final comments? 

● Remind to take survey. 

 

 

 

 


